21 de maig de 2021

Wifi ON/OFF amb un botó a RouterOS (Mikrotik hAP ac^2)

Si heu seguit el meu bloc, potser sabreu que m'agrada apagar la xarxa sense fils quan ningú l'utilitza, ja sigui amb un botó (TP-Link TL-WR14032ND o TP-Link WDR3600) o automàticament per temps si no hi ha ningú connectat (TP-Link WDR3600). En tots aquests casos, l'encaminador funcionava amb un sistema Openwrt.

El meu nou encaminador (router) és un model Mikrotik hAP ac^2 que treballa amb RouterOS (vegeu les primeres impressions) i lògicament, no podia ser menys i hi havia d'afegir aquesta funcionalitat.

L'encaminador disposa d'un botó (programable) en la part superior, així que anem a veure com ho podem fer. En primer lloc, creem un script per commutar l'estat de la xarxa sense fils. El codi pot ser similar a:

:log info message=("> Mode button was pressed");
:local i
:if ( [/int wir get 0 disabled ] = true ) do={
:log info message=("--> Wifi ON");
:foreach i in= [ /int wir find ] do={ :int wir enable $i };
} else={
:log info message=("-- > Wifi OFF");
:foreach i in= [ /int wir find ] do={ :int wir disable $i };
}

L'hem d'afegir usant el menú "System -> Scripts -> Add New", donant-li un nom i verificant les prioritats tal com es veu en la imatge:


En aquest moment podem executar-lo amb "Run Script" i verificar el seu bon funcionament: la xarxa sense fils s'ha d'apagar/engegar amb cada execució, i un missatge ha d'aparèixer si accedim al menú "Log". 

Ara ja només queda associar-lo al botó. Per això accedim al menú "Terminal" (o connectem per ssh) i teclegem la comanda següent:

/system routerboard mode-button set on-event=wifi_on_off enabled=yes

Amb això tenim el botó per apagar/engegar la xarxa sense fils configurat! Ja em direu què us sembla...


17 de maig de 2021

Mikrotik hAP ac^2 amb RouterOS: primeres proves

 Ja fa un temps que pensava canviar l'encaminador (router) de casa. Les últimes millores en la línia (ara amb 600MB simètrics) han fet que el meu antic TP-Link WDR3600 amb Openwrt/LEDE, no acabi de treure'n tot el profit possible.

Buscava un encaminador amb les següents característiques :

  • Prou potent per aconseguir la màxima velocitat de la línia.
  • Fiable.
  • Que pogués suportar Openwrt (mínim 8MB/64MB de memoria Flash/RAM respectivament).
  • Que permetés algun tipus de bloquejador d'anuncis (quan t'hi acostumes, no hi ha marxa enrere).
  • No molt car.
De fa temps, tenia molt bones referències dels encaminadors de la marca Mikrotik, més orientats als sistemes professionals que als domèstic, però fins ara els havia descartat per què eren cars, funcionaven amb un sistema propi (RouterOS) i eren complexos de configurar.

Doncs bé, per fer-ho curt, m'he decidit a provar el model Mikrotik hAP ac2 :

  • És un quàdruple-core, amb potència de sobres.
  • Té 16MB de Flash i 128MB de RAM.
  • Suporta Openwrt, tot i que en principi és millor deixar-lo amb el seu sistema propi, RouterOS.
  • Es pot trobar per menys de 65€.
  • Té un USB 3.0 per expandir-lo i un botó configurable.
Amb la tranquil·litat de saber que el puc passar a Openwrt si calgués, he començat a instal·lar-lo. No és trivial, ja que els menús avançats poder espantar una mica, però amb un xic de coneixement i consultant els fòrums habituals, tampoc no ha resultat cap drama.

I arriba l'hora de la veritat :




Tal com es pot veure, treballa amb els 600MB simètrics sense problemes. I tot plegat amb un 5%-10% de la CPU de l'encaminador !!

De moment, molt content amb la compra 😀

8 de juliol de 2020

Ionic 5 amb Angular

Fa una mica més de 2 anys, vaig presentar una sèrie d'articles per explicar pas a pas com fer una aplicació multi-plataforma amb Ionic. Es tractava d'indicar a quina hora surt i s'amaga el sol en un lloc determinat, en un dia determinat. Ha passat el temps i un parell de versions d'Ionic, així que anem a veure què ha canviat, reformulant la mateixa idea, però ara amb Ioniv 5.

En primer lloc, instal·lem o actualitzem la versió de Ionic:
npm install -g @ionic/cli
Tot seguit, creem una aplicació base, amb pestanyes:
ionic start SunriseSunset tabs
Passarem per diverser preguntes senzilles:
  • com a Framework, escollim Angular 
  • escollim també integrar l'aplicació amb Capacitor.
  • no cal crear un compte a Ionic.
Tot seguit podem anar al directori de l'aplicació i engegar-la per veure el seu aspecte:
cd ./SunriseSunset
ionic serve
Amb això l'aplicació serà compilada i s'obrirà automàticament en el navegador, mostrant una pantalla similar a:

Res gaire espectacular de moment, però almenys tenim una base per on començar !!

Si mirem l'estructura del projecte, veurem que cada pàgina està definida en el seu propi mòdul, i amb el seu fitxer de routing. També s'inclou el fitxer de specs per poder testejar la pàgina. És important mantenir cada pàgina en el seu propi directori, ja que això facilitarà l'organització del projecte.

4 de juliol de 2020

ERROR: node-sass errors.missingBinary() [SOLUCIONAT]

Us ha passat mai que en anar a executar la vostre aplicació Ionic/Angular us salti un error del tipus ?
  • Node Sass could not find a binding for your current environment

I que un npm install clàssic tampoc no ho solucioni ?

No patiu, que no és tan greu. L'error apareix típicament quan hem canviat la versió del node. Llavors, simplement cal recompilar el paquet node-sass a mà:
npm rebuild node-sass
I tal com podeu veure en la imatge següent, després ja podrem executar l'aplicació normalment:


Ja em comentareu si us ha servit !

30 de juny de 2020

Openwrt (LEDE) 19.07 amb "Software flow offloading"

Ja fa temps que tenia pendent actualitzar el firmware del meu encaminador (router) TP-Link WDR3600. A part de la facilitat de "trastejar" en general, jo destacaria la possibiltat de bloquejar anuncis com una de les principals avantatges d'un firmware Openwrt/LEDE sobre un de fàbrica.

Com que havia passat temps, vaig haver de fer una actualització sense preservar la configuració. La versió instal·lada és la 19.07.3 i, utilitzant com a referència la còpia de seguretat anterior, no vaig tenir gaires dificultats en posar-la en marxa. De seguida vaig percebre millores tan a nivell visual com de gestió. En general, es percep una versió molt polida, molt recomanable.

Ara, el complement adblock per bloquejar els anuncis es pot afegir des de l'entorn gràfic, i es configura de manera molt senzilla. En cas de dubte, utilitzeu els comentaris per preguntar i, si puc, us donaré un cop de mà :-)

Tot seguit, vaig anar a fer una prova de velocitat, i els resultats no van ser gaire bons:



Fa uns anys, hauria signat aquests valors sense pensar-ho, però la meva connexió hauria de ser 600MB simètrics... Ja m'esperava que podia tenir problemes amb la velocitat, ja que tenia un firmware personalitzat amb fastpath per assolir la màxima velocitat.

Però no em va costar gaire trobar les opcions per aconseguir el mateix resultat (ara ja disponible en el firmware oficial). Efectivament, n'hi ha prou d'activar l'opció de "Software flow offloading":



Simplement amb aquest canvi, els resultat milloren dràsticament:


Com es pot observar, s'obtenen un 500MB simètrics, que ja s'apropen força al contractat. Els 100MB aprox. que falten poden ser deguts a l'ús de la resta d'usuaris en aquell moment, a que el proveidor no estava donant tot l'ample de banda, o molt més probablement, a que l'encaminador ja està en els seus límits (al cap i a la fi, ja té uns bons anys).

Sigui com sigui, estic content del canvi. Més fàcil i ràpid del que havia previst !

23 de maig de 2020

Instal·lar Docker a Ubuntu

Docker és possiblement el gestor de contenidors de programari més utilitzat actualment. Un contenidor ens permet obtenir els mateixos avantatges que una màquina virtual, però funcionant directament sobre el sistema operatiu hoste. Això permet que siguin més lleugers i eficients en general.

Per instal.lar Docker a Ubuntu, seguim el procediment descrit en la seva pàgina. De les possibles opcions, la més senzilla, sobretot de cara a possibles actualitzacions, és utilitzar un repositori. Per tant, primer instal·lem el repositori de Docker:
sudo apt-get update
sudo apt-get install apt-transport-https ca-certificates curl \
     gnupg-agent software-properties-common
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | \
     sudo apt-key add -
sudo add-apt-repository "deb [arch=amd64] \
     https://download.docker.com/linux/ubuntu $(lsb_release -cs) stable"

I tot seguit ja podem instal·lar el Docker Engine:
sudo apt-get update
sudo apt-get install docker-ce docker-ce-cli containerd.io

Si tot és correcte, ja estem en condicions de provar el nostre primer contenidor:
sudo docker run hello-world
El resultat ha de ser similar al de l'imatge:
Amb això, ja tenim l'entorn preparat per fer les primeres passes amb contenidors Docker. Tot a punt per divertir-se !!

10 d’abril de 2019

slang-ed: editor senzill de fitxers de traduccions [V0.2.0]

Fa un temps vaig parlar de com podem traduir la nostra aplicació Ionic/Angular a diversos idiomes. En concret, vàrem veure que gràcies a utilitzar la llibreria ngx-translate, en teníem prou d'editar uns fitxers JSON amb les traduccions en cada idioma, per a poder utilitzar-les després en el nostre codi.

Si us interessa el seu ús real en una aplicació Ionic/Angular/Electron començant des de zero, podeu seguir la sèrie completa aquí (o descarregar el codi des del seu repositori github).

L'edició "a mà" d'aquests fitxers de traduccions no és difícil, però és pesada i subjecta a errades i oblits. Si heu de fer-ho professionalment, us aconsello la proposta de pagament BabelEdit. Alternativament, podeu utilitzar lliurement l'editor que he anat fent a estones lliures: slang-ed.


slang-ed: Editor senzill de fitxers d'idioma

Es tracta d'una aplicació Electron/Ionic 4 per a editar fitxers i18n de traduccions d'idioma. Està pensat per facilitar la traducció del vostre contingut a diferents idiomes quan s'utilitza ngx-translate com a llibreria d'internacionalització (i18n) per Angular. Permet l'edició dels fitxers JSON de les traduccions de forma senzilla.

Crear un Nou Projecte:
  1. "Inicia des de..." per obrir un directori Angular/Ionic ja preparat:
    • busca una estructura de directoris típica "src/assets/i18n"
    • els fitxers d'idioma han de ser JSON amb un nom que segueixi l'abreviació amb 2 caràcters (per exemple, 'ca.json').
  2. Guardar com Nou Projecte” per a crear un fitxer de projecte slang-ed.
Treballant en un Projecte:
  1. "Obrir Projecte" per carregar les traduccions actuals.
  2. Tot seguit edita els identificadors i les traduccions tant com calgui.
  3. "Guardar Traduccions" per actualitzar els fitxers d'idioma i18n.
  4. "Guardar Projecte" per actualitzar el fitxer de projecte amb les noves traduccions.
Editar Traduccions:
  • "Afegir Arrel" per afegir un node al nivell de l'arrel.
  • "Afegir Node" per afegir un node intermig al nivell actual.
  • "Afegir paraula" per afegir una paraula a traduir en el nivell actual.
  • "Esborrar" per esborrar el node/paraula actual.
  • "Desfés" / "Refés" per recuperar en cas d'errada.

Pendent (To Do):
  • Gestionar els fitxers del projecte: crear, obrir, desar (això permetrà emmagatzemar informació "extra" a les definicions d'idioma). [V0.2.0]
  • Suport per a propietats en les definicions d'idioma: comentari (per a traductors), aprovat (traducció verificada), foundInSrc (clau present en el codi font), conserva (no eliminar la clau, encara que no es trobi en el codi font). 
  • Afegir / eliminar idiomes en el projecte actual. 
  • Desar els fitxers i18n en el format d'objecte (en lloc del format de cadena de clau completa que s'utilitza ara). 
  • Edició de múltiples paraules alhora (per exemple, tots els descendents d’un determinat node). 
  • Indicar les traduccions, aprovacions o comentaris pendents... 
  • Altres: els vostres suggeriments seran sempre benvinguts ;-)
Descàrrega:

Actualment hi ha disponible la V0.2.0. Sense gaire floritures, permet fer la feina. Podeu descarregar-la directament del repositori de github:
Si us animeu a provar slang-ed, ja em comentareu què us sembla !